Uploaded image for project: 'Blossom'
  1. Blossom
  2. BLOSSOM-256

Adapt Blossom module for Magnolia 6

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.2.1
    • Fix Version/s: 3.3
    • Component/s: None
    • Labels:
      None
    • Patch included:
      Yes
    • Epic Link:
    • Sprint:
      SPA Editor 4
    • Story Points:
      3
    • Magnolia Release:
      6.1.2

      Description

      I've updated my running magnolia instance from 6.0 to 6.1 without updates to blossom (using 3.2.1).

      I'm getting the following error when opening a dialog or pageproperties -> magnolia_blossom_error.txt

      This is caused due to a signature change in the code which came with Magnolia 6.1.

       

      Solutions:

      Replace the existing constructor with the new new constructor in the following code in the class BlossomFormDialogPresenter.

      @Inject
      public BlossomFormDialogPresenter(DialogDefinitionRegistry dialogDefinitionRegistry, FormBuilder formBuilder, ComponentProvider componentProvider, DialogActionExecutor executor, FormView view, I18nizer i18nizer, SimpleTranslator i18n) {
          super(dialogDefinitionRegistry, formBuilder, componentProvider, executor, view, i18nizer, i18n);
          this.dialogDefinitionRegistry = dialogDefinitionRegistry;
      } 

        Attachments

          Activity

            People

            • Assignee:
              rsiska Robert Šiška
              Reporter:
              tom_trapp Tom Trapp
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: