Uploaded image for project: 'Build'
  1. Build
  2. BUILD-363

Raise required maven version to 3.3.9

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Neutral
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: POMs 38
    • Component/s: Poms
    • Labels:
      None

      Description

      Maven 3.2.3 (Aug 2014) is our current minimum required build version. For further evolution of the POMs, it might be counter-productive to go back and maintain this support (e.g. BUILD-350, minor but still).

      Besides, most devs and build tooling are operating with Maven 3.5 or 3.6 by now.
      So let's bump this to 3.3.9 (Nov 2015, still a conservative baseline).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mgeljic Mikaël Geljić
              Reporter:
              mgeljic Mikaël Geljić
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: