Uploaded image for project: 'Content Translation Extended (CTX)'
  1. Content Translation Extended (CTX)
  2. EXCONTRANS-305

Workflows broken because of WorkItemHandlers package change between 2.0 and 2.0.2

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.0.3
    • Component/s: Core
    • Labels:
      None
    • Environment:
      Independent

      Description

      The class TranslationWorkItemHandlerDefinition in magnolia-content-translation-support-ext-core was moved from 

      info.magnolia.translation.ext.workflow.workitem

      to

      info.magnolia.translation.ext.core.workflow.workitem

      without providing an update task.

      So if the module version 2.0 is installed before using version 2.0.2 the jcr config is invalid and workItemHandlers of Workflow can be no longer used. 

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                trung.luu Trung Luu
                Reporter:
                joergwirsig Jörg Wirsig
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0d
                  0d
                  Logged:
                  Time Spent - 2.5h
                  2.5h