Uploaded image for project: 'Magnolia'
  1. Magnolia
  2. MAGNOLIA-4295 jcr: utils
  3. MAGNOLIA-4329

refactor NodeUtil as discussed during Code-Review

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.5
    • Component/s: None
    • Labels:
      None
    • Magnolia Release:
      4.5

      Description

      • replace NodeIterator with Iterable<Node> for better usage in enhanced for-loops
      • consistently use typed Lists instead of Collection
      • rename getChildren methods to getNode
      • rename getNodeIterator to getNode
      • default should be to return Iterable<Node> - not List

        Attachments

          Activity

            People

            Assignee:
            dlipp Daniel Lipp
            Reporter:
            dlipp Daniel Lipp
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: