Uploaded image for project: 'Magnolia'
  1. Magnolia
  2. MAGNOLIA-6814

Update 3rd-party libraries for next major 5.5 release

    Details

    • Type: Epic
    • Status: Closed
    • Priority: Neutral
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.5
    • Component/s: None
    • Labels:
      None
    • Epic Name:
      Update 3rd-party libraries for 5.5
    • Release notes required:
      Yes
    • Story Points:
      0
    • Magnolia Release:
      5.5

      Description

      The following libraries have updates atm in core (23.2.2016): (by definition all our dependencies should at least be managed in the core parent)

      cglib:cglib-nodep ....................................... 3.1 -> 3.2.0 MAGNOLIA-6665 
      com.google.auto.factory:auto-factory .......... 0.1-beta1 -> 1.0-beta3
      com.google.guava:guava .................................. 18.0 -> 19.0
      com.google.inject:guice ................................... 3.0 -> 4.0 MAGNOLIA-6337 
      com.google.inject.extensions:guice-multibindings .......... 3.0 -> 4.0
      com.mockrunner:mockrunner-servlet ..................... 1.0.4 -> 1.1.1
      com.mycila.guice.extensions:mycila-guice-closeable .. 3.5.ga -> 3.6.ga
      com.mycila.guice.extensions:mycila-guice-injection .. 3.5.ga -> 3.6.ga
      com.mycila.guice.extensions:mycila-guice-jsr250 ..... 3.5.ga -> 3.6.ga
      commons-betwixt:commons-betwixt ............... 0.8 -> 20030211.133854
      javax.el:javax.el-api ............................. 2.2.4 -> 3.0.1-b04
      javax.servlet:servlet-api ......................... 2.5 -> 3.0-alpha-1
      javax.servlet.jsp:jsp-api ........................... 2.1 -> 2.2.1-b03
      junit:junit ............................................. 4.11 -> 4.12
      net.sourceforge.htmlunit:htmlunit ....................... 2.15 -> 2.19
      org.apache.commons:commons-collections4 ................... 4.0 -> 4.1 DEV-266
      org.apache.commons:commons-lang3 .......................... 3.1 -> 3.4 DEV-241 
      org.apache.commons:commons-pool2 ........................ 2.2 -> 2.4.2 DEV-267
      org.apache.httpcomponents:httpclient .................. 4.3.5 -> 4.5.1 DEV-268 
      org.apache.httpcomponents:httpmime .................... 4.3.5 -> 4.5.1 DEV-268
      org.apache.jackrabbit:jackrabbit-core ................ 2.8.0 -> 2.12.4 DEV-278
      org.apache.jackrabbit:jackrabbit-jcr-commons ......... 2.8.0 -> 2.12.4 DEV-278
      org.apache.tika:tika-core ................................ 1.6 -> 1.12
      org.apache.tika:tika-parsers ............................. 1.6 -> 1.12
      org.apache.velocity:velocity ........................ 1.5 -> 1.7-beta1
      org.bouncycastle:bcmail-jdk15on ......................... 1.46 -> 1.54 MAGNOLIA-6703
      org.bouncycastle:bcpg-jdk15on ........................... 1.46 -> 1.54 MAGNOLIA-6703
      org.bouncycastle:bcprov-jdk15on ......................... 1.46 -> 1.54 MAGNOLIA-6703
      org.easymock:easymock ..................................... 2.4 -> 3.4
      org.easymock:easymockclassextension ....................... 2.4 -> 3.2
      org.freemarker:freemarker ........................... 2.3.21 -> 2.3.25 MAGNOLIA-6373
      org.glassfish.web:javax.el ............................ 2.2.4 -> 2.2.6
      org.hibernate:hibernate-validator ........ 5.1.3.Final -> 5.3.0.Alpha1
      org.mockito:mockito-core ....................... 1.10.8 -> 2.0.42-beta
      org.powermock:powermock-api-mockito ................... 1.5.6 -> 1.6.4
      org.powermock:powermock-module-junit4 ................. 1.5.6 -> 1.6.4
      org.projectlombok:lombok ............................ 1.14.8 -> 1.16.6
      org.reflections:reflections .......................... 0.9.9 -> 0.9.10
      org.slf4j:jcl-over-slf4j ............................. 1.7.7 -> 1.7.16
      org.slf4j:slf4j-api .................................. 1.7.7 -> 1.7.16
      org.slf4j:slf4j-log4j12 .............................. 1.7.7 -> 1.7.16
      org.slf4j:slf4j-simple ............................... 1.7.7 -> 1.7.16
      org.yaml:snakeyaml ...................................... 1.14 -> 1.17
      uk.com.robust-it:cloning .............................. 1.9.1 -> 1.9.2
      xerces:xercesImpl .................................... 2.8.1 -> 2.11.0
      xmlunit:xmlunit ........................................... 1.5 -> 1.6
      

      Please use the following command to list possible dependency updates in maven projects: mvn versions:display-dependency-updates

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                mmuehlebach Michael Mühlebach
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: