Uploaded image for project: 'Magnolia'
  1. Magnolia
  2. MAGNOLIA-6924

magnolia enterprise not start in 5.4.10, cause magnolia-lang-ko

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 5.4.10
    • Fix Version/s: None
    • Component/s: i18n
    • Labels:
      None

      Description

      On a new project in 5.4.10 Magnolia can't start.

      I excluded the magnolia-lang-ko and it works.

      <dependency>
      <groupId>info.magnolia</groupId>
      <artifactId>magnolia-empty-webapp</artifactId>
      <type>pom</type>
      <exclusions>
      <exclusion>
      <groupId>info.magnolia.lang</groupId>
      <artifactId>magnolia-lang-ko</artifactId>
      </exclusion>
      </exclusions>
      </dependency>
      <dependency>
      <groupId>info.magnolia</groupId>
      <artifactId>magnolia-empty-webapp</artifactId>
      <type>war</type>
      <exclusions>
      <exclusion>
      <groupId>info.magnolia.lang</groupId>
      <artifactId>magnolia-lang-ko</artifactId>
      </exclusion>
      </exclusions>
      </dependency>
      </dependencies>

      because the module descriptor depends on scheduler 2.2.3 instead od 2.2.1, see the following dependency:tree

      [INFO] +- info.magnolia:magnolia-empty-webapp:pom:5.4.10:compile
      [INFO] | +- info.magnolia.ui:magnolia-ui-admincentral:jar:5.4.10:compile
      [INFO] | | +- info.magnolia.core:magnolia-configuration:jar:5.4.10:compile
      [INFO] | | | +- org.apache.jackrabbit:jackrabbit-jcr-commons:jar:2.8.0:compile
      [INFO] | | | - org.atteo:evo-inflector:jar:1.2.1:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-framework:jar:5.4.10:compile
      [INFO] | | | - org.apache.commons:commons-compress:jar:1.8.1:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-workbench:jar:5.4.10:compile
      [INFO] | | +- info.magnolia:magnolia-module-imaging:jar:3.2:compile
      [INFO] | | | +- info.magnolia:magnolia-imaging-support:jar:3.2.7:compile
      [INFO] | | | +- com.twelvemonkeys.imageio:imageio-jpeg:jar:3.1.0:compile
      [INFO] | | | | +- com.twelvemonkeys.imageio:imageio-core:jar:3.1.0:compile
      [INFO] | | | | +- com.twelvemonkeys.imageio:imageio-metadata:jar:3.1.0:compile
      [INFO] | | | | +- com.twelvemonkeys.common:common-lang:jar:3.1.0:compile
      [INFO] | | | | +- com.twelvemonkeys.common:common-io:jar:3.1.0:compile
      [INFO] | | | | - com.twelvemonkeys.common:common-image:jar:3.1.0:compile
      [INFO] | | | - com.jhlabs:filters:jar:2.0.235:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-api:jar:5.4.10:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-vaadin-theme:jar:5.4.10:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-mediaeditor:jar:5.4.10:compile
      [INFO] | | +- info.magnolia.task:magnolia-task-management:jar:1.1:compile
      [INFO] | | | - org.apache:jackrabbit-ocm:jar:2.0.0:compile
      [INFO] | | | +- commons-lang:commons-lang:jar:2.1:compile
      [INFO] | | | - cglib:cglib:jar:2.2:compile
      [INFO] | | | - asm:asm:jar:3.1:compile
      [INFO] | | +- org.apache.commons:commons-lang3:jar:3.1:compile
      [INFO] | | +- org.vaadin.addon:easyuploads:jar:7.0.0:compile
      [INFO] | | - org.vaadin.addons.lazyquerycontainer:vaadin-lazyquerycontainer:jar:7.4.0.1:compile
      [INFO] | | +- com.vaadin:vaadin-client-compiled:jar:7.4.7:compile
      [INFO] | | - com.vaadin:vaadin-themes:jar:7.4.7:compile
      [INFO] | +- info.magnolia.widgetset:magnolia-vaadin-widgetset:jar:5.4.10:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-vaadin-common-widgets:jar:5.4.10:compile
      [INFO] | | | +- com.vaadin:vaadin-shared:jar:7.4.7:compile
      [INFO] | | | | +- com.vaadin.external.flute:flute:jar:1.3.0.gg2:compile
      [INFO] | | | | +- com.vaadin.external.streamhtmlparser:streamhtmlparser-jsilver:jar:0.0.10.vaadin1:compile
      [INFO] | | | | - com.vaadin.external.google:guava:jar:16.0.1.vaadin1:compile
      [INFO] | | | +- org.vaadin.addons:cssinject:jar:2.0.3:compile
      [INFO] | | | +- org.vaadin.addons:aceeditor:jar:0.8.11:compile
      [INFO] | | | +- com.googlecode.mgwt:mgwt:jar:1.1.2:compile
      [INFO] | | | +- org.vaadin.addons:gwt-graphics:jar:1.0.0:compile
      [INFO] | | | - org.vaadin.addons:ckeditor-wrapper-for-vaadin:jar:7.8.8:compile
      [INFO] | | - info.magnolia.pages:magnolia-pages-editor-widget:jar:5.4.9:compile
      [INFO] | +- info.magnolia.pages:magnolia-pages-app:jar:5.4.9:compile
      [INFO] | | +- info.magnolia:magnolia-i18n:jar:5.4.10:compile
      [INFO] | | | - org.jsoup:jsoup:jar:1.8.1:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-contentapp:jar:5.4.10:compile
      [INFO] | | | - uk.com.robust-it:cloning:jar:1.9.1:compile
      [INFO] | | | - org.objenesis:objenesis:jar:2.1:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-dialog:jar:5.4.10:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-form:jar:5.4.10:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-actionbar:jar:5.4.10:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-vaadin-integration:jar:5.4.10:compile
      [INFO] | | | - com.google.code.gson:gson:jar:2.2.2:compile
      [INFO] | | +- info.magnolia.ui:magnolia-ui-imageprovider:jar:5.4.10:compile
      [INFO] | | +- com.vaadin:vaadin-server:jar:7.4.7:compile
      [INFO] | | | - com.vaadin:vaadin-sass-compiler:jar:0.9.12:compile
      [INFO] | | | - org.w3c.css:sac:jar:1.3:compile
      [INFO] | | +- javax.jcr:jcr:jar:2.0:compile
      [INFO] | | +- com.google.inject:guice:jar:3.0:compile
      [INFO] | | | - aopalliance:aopalliance:jar:1.0:compile
      [INFO] | | +- com.thoughtworks.proxytoys:proxytoys:jar:1.01-MAGNOLIA-5317-patched:compile
      [INFO] | | +- com.google.guava:guava:jar:18.0:compile
      [INFO] | | +- org.slf4j:slf4j-api:jar:1.7.7:compile
      [INFO] | | - javax.inject:javax.inject:jar:1:compile
      [INFO] | +- info.magnolia.security:magnolia-security-app:jar:5.4.10:compile
      [INFO] | | - commons-collections:commons-collections:jar:3.2.1:compile
      [INFO] | +- info.magnolia.about:magnolia-about-app:jar:5.4.10:compile
      [INFO] | +- info.magnolia.jcrbrowser:magnolia-jcr-browser-app:jar:5.4.10:compile
      [INFO] | +- info.magnolia.scheduler:magnolia-module-scheduler:jar:2.2.1:compile

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            kaste Andrea Castelli
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: