Uploaded image for project: 'Magnolia'
  1. Magnolia
  2. MAGNOLIA-7171

Very Old Gson Dependency is used in magnolia-ui-project

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 5.5.6
    • Fix Version/s: None
    • Component/s: core
    • Labels:
      None

      Description

      Gson Version 2.2.2 is very old (July 2012) which makes impossible to integrate libs which require a more recent version of gson.

      [INFO] ------------------------------------------------------------------------
      [INFO]
      [INFO] — maven-dependency-plugin:2.8:tree (default-cli) @ riedel —
      [INFO] at.pixelart.riedel:riedel:pom:1.0-SNAPSHOT
      [INFO] - info.magnolia.pages:magnolia-pages-app:jar:5.5.6:compile
      [INFO] - info.magnolia.ui:magnolia-ui-vaadin-integration:jar:5.5.6:compile
      [INFO] - com.google.code.gson:gson:jar:2.2.2:compile
      [INFO]

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                tpeintner Thomas Peintner
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: