Uploaded image for project: 'Backup'
  1. Backup
  2. MGNLBACKUP-136

After restore Magnolia can't start with 'Unsupported type 17 [1.4.200/3]' exception

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2.4, 2.3.1
    • Fix Version/s: 2.2.5, 2.3.2
    • Labels:
    • Release notes required:
      Yes
    • Sprint:
      Maintenance 21
    • Story Points:
      1
    • Magnolia Release:
      5.6.14, 5.7.8

      Description

      Backup module bundle uses older version of h2-1.4.192, unfortunately this is not compatible with newer version h2-1.4.200 used in magnolia enterprise bundle (MAGNOLIA-7727)

      After restore with version h2-1.4.192(used in backup module bundle 2.4.4 and 2.3.1) then Magnolia using h2-1.4.200 (Magnolia 5.4.16...) fails during start with

      javax.jcr.RepositoryException: Cannot instantiate persistence manager org.apache.jackrabbit.core.persistence.pool.H2PersistenceManager
      Caused by: java.lang.IllegalStateException: Unable to read the page at position 549755933190 [1.4.200/6]
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mdivilek Milan Divilek
              Reporter:
              mdivilek Milan Divilek
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: