MGNLCACHE-57 introduced isCacheableVoters configuration under Default cache policy to have all cache voters at one place:
- Move this configuration to CachePolicy interface next to the voters for bypass. I'd also suggest to make it more powerful than just cacheable/noncacheable. I could return TTL and the logic from info.magnolia.module.cache.executor.Store#getTimeToLive should go there.
- Rename CachePolicy/voters to something more explanatory (bypass/shouldBypass).
Move also other configuration there that's spread across other places (e.g Store also has a compressible configuration item)- this is no longer the case