Uploaded image for project: 'Magnolia DX Core'
  1. Magnolia DX Core
  2. MGNLEE-124

Errors in repository upgrading from Magnolia Enterprise 3.0 to Magnolia Enterprise 3.5.8

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Obsolete
    • Affects Version/s: 3.0, 3.5.8
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:
      Red Hat Enterprise Linux ES release 3, JBOSS 4.0.4.GA, Java 1.6.0_01, Magnolia Enterprise 3.0

      Description

      We're trying to upgrade Magnolia Enterprise from 3.0 to 3.5.8. We've followed all the necessary steps (replace libraries, modify xml's and delete indexes) with the help of Alvaro Arce from Magnolia. The problem is when we start the upgrade process, we start jboss and magnolia and then thru a browser we get the screen that says that some items will be installed and when we click Install we get the following error on screen:

      Could not perform installation: Error importing config.server.filters: a node with uuid 5f291d19-cb25-45b2-aaf2-96e6687880b2 already exists!

      And I get the following on the server.log:

      27 Fallback to nt:unstructured due to unknown node type
      '

      {http://www.jcp.org/jcr/xpath-functions/1.0}

      root' of node /
      2008-11-19 13:32:27,695 INFO [STDOUT] WARN
      org.apache.jackrabbit.core.NodeImpl NodeImpl.java(<init>:140) 19.11.2008
      13:32:27 Fallback to nt:unstructured due to unknown node type
      '{}content' of node /xs:server/xs:filters
      2008-11-19 13:32:27,698 INFO [STDOUT] ERROR
      info.magnolia.module.ui.ModuleManagerWebUI
      ModuleManagerWebUI.java(run:124) 19.11.2008 13:32:27 Could not perform
      installation: Error importing config.server.filters: a node with uuid
      5f291d19-cb25-45b2-aaf2-96e6687880b2 already exists!
      java.lang.RuntimeException: Error importing config.server.filters: a
      node with uuid 5f291d19-cb25-45b2-aaf2-96e6687880b2 already exists!

      I've searched for that node using jcr query but I don't get any response but time of execution. Also I've tried deleting /server/filters before upgrade but I keep getting the same error. I would appreciate any assistance.

      Thanks for your help,

        Attachments

          Activity

            People

            • Assignee:
              gjoseph Magnolia International
              Reporter:
              map_andago Tecnico de Andago
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: