Uploaded image for project: 'OpenSocial Connector (closed)'
  1. OpenSocial Connector (closed)
  2. MGNLOPENSOCIAL-2

Remove workarounds in OpenSocials dependency management as soon as the real issues are fixed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: container
    • Labels:
      None

      Description

      Right now there's a few workarounds in the setup of OpenSocial due to conflicts in versions:

      1.) Shindig 2.0.x requires ehcache 2.2.0 - we have to run with version 1.5.0 as required by Magnolia, as the newer one is not backwords compatible.

      2.) OpenSocial requires a newer version of nekohtml but we can't exclude the old one contained in Daisydiff right now. Workaround here is to add an explicit dependency to the desired version in the webapp's pom.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dlipp Daniel Lipp
              Reporter:
              dlipp Daniel Lipp
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:

                  Checklists

                  Bug DoR
                  DoD