Uploaded image for project: 'Magnolia UI'
  1. Magnolia UI
  2. MGNLUI-4727

Update JQueryWrapper to jQuery 3 API

    Details

    • Type: Task
    • Status: Closed
    • Priority: Neutral
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 6.0
    • Component/s: None
    • Labels:
      None
    • Release notes required:
      Yes
    • Documentation update required:
      Yes
    • Sprint:
      Basel 159
    • Story Points:
      1
    • Magnolia Release:
      6.0

      Description

      While working on MGNLUI-4640 I ran into one issue caused by the major upgrade from jQuery 1.x to 3.x. JQueryWrapper was accessing a jQuery function that has since been removed.

      Rather than react to those bugs one by one, which is extremely hard as no logging is provided, we should rather do a thorough migration of that class and package to the new API.

      Try using the jQuery Migration Plugin shim. 

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mmichel Maxime Michel
                Reporter:
                mmichel Maxime Michel
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: